Home

Awakening: The Skyward Castle Forum

Walkthrough
PC Download PC Download Apple App Store

Search Forums:

Awakening The Skyward Castle Forum


By tracy
08/28/2012
Welcome to the Awakening The Skyward Castle Forum! Feel free to chat, ask questions, and connect with other fans!

Awakening the Skyward Castle is the last chapter of the Awakening games where we join Princess Sophia on the last leg of her journey to find and save her people.

How do you feel this game measures up to the previous Awakening games?
By steph
09/16/2012
i am trying to get rid of the gargoyle, i have the boiling water above him and he is frozen, i dont think i can go any further till i have the final piece of quilt, how do i get this?
By moi
09/17/2012
You get the final quilt piece after you destroy the gargoyle
By steph
09/17/2012
thank you, but i cant seem to destroy the gargoyle, i have the bow and arrow which i have tried shooting at, i have the reigning star and the tesseract prism. the boiling water is above the gargoyle. help, its driving me mad!!
By steph
09/17/2012
ive done !!!, it took so long to get the arrows in the right place! thanks.
By newpamplayer
09/17/2012
Where do I need to use the saw in order to make the bow??
By biglug 102966
09/18/2012
how do u open the satchel to get paper

By tracy
09/20/2012
You need to use the saw on the Goldleaf branch to make the bow. It will start a mini-game where you have to carve the bow from the branch.
By sparky
09/22/2012
I put the fire charm in the freezer, only now it is telling me that I need it to melt the water pipe! Am I stuck?

By tracy
09/25/2012
Hi Sparky!

You need to get that Fire Charm back. If it's in the freezer right now, then it's next to the Frost Charm. You need that too. Use the Broken Chair leg on the Frost Charm to dig it out. The fire charm will go back into your inventory so you can use it on the water pipe. Check out the walkthrough for this section. I just finished chapter 3!

Thanks!

Tracy
By tcsfriend
10/18/2012
I am stuck in the glowing colums. the paper fell down and now I cannot get it back to draw the last rune. I don't want to start all over again!!!
By tonihamrick
01/10/2013
I can't get the saw to work on the branch in the weapons cabinet. i tried sawing but nothing happens. i tried putting the saw on the branch and clicking but nothing. can anyone help?
toni
By anges35
06/20/2013
This is for iPad version

I am also stuck like toni tr...]toni, are you using the iPad version?



By anges35
06/20/2013
Sorry, my post seems to have g...]toni, are you using the iPad v...]
By bev
07/18/2013
I am not able to use the poker on the embers in the fireplace. frustrated
By bev
07/18/2013
I am not able to use the poker on the embers in the fireplace. frustrated
By eddy
01/26/2014
help on fire poker and embers
By telamarine
05/27/2014
I lost the paper for the charcoal rubbing. it slipped behind the inventory bar and I can't grab it without going back a scene. How do I reset the chapter?
By octopus
04/22/2015
I, too, am stuck behind the glowing columns with paper that will not adher to the last piece of the symbol. Also, I can' together the ropes to work to move the banner. Is there an answer without going back to the beginning of the game?
By sprouts
08/05/2015
I'm also stuck trying to saw the bow - also on iPad! Anyone have any answers on this or is it another glitch?
By mama
12/26/2016
I've lost the fly for the spider's web in the squabbit's den. Where did it go?
New Games